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 to use it as part of the development 
ET+OS is a network software suite 

se NET+OS. To complete the tasks 

re.

ent board systems.
Using this guide

About this guide
This guide describes NET+OS with Green Hills and how
cycle. Part of the NET+OS integrated product family, N
optimized for the NET+ARM.

Who should read this guide
This guide is for software engineers and others who u
described in this guide, you must:

Be familiar with installing and configuring softwa

Have sufficient user privileges to do these tasks.

Be familiar with network software and developm



Conventions used in this guide

uide
stalled in the default installation directory, 

in the numbers that follow netos, for 

riables, and document titles.

 components, items on the screen; filenames, 
ds. In most cases, software release information is 
enames and pathnames; for example, C:\netos\ 

rst word is the menu name; the words that follow 

mples.
1 0      n  n  n  n  n  n  n  

This guide uses several typographic conventions:

Software release level assumed in this g
Instructions in this guide assume that NET+OS is in
C:\netos. The software release level is displayed 
example, C:\netos72.

Convention Used for

italic type Emphasis, new terms, va

bold type Menu commands, dialog
pathnames, and comman
not included with the fil
instead of C:\netos72\.

menu name > option Menu commands. The fi
are menu selections.

monospaced type Code and command exa
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Related documentation
grammer interfaces (APIs) that are provided 
os\docs.

her components, review the documentation 

+OS hardware documentation.

 on the Web site. 

ion received in the NET+OS package and the 
tent is the latest version.
NET+OS online help describes the application pro
with NET+OS. The online help is located in C:\net

For information about third-party products and ot
CD-ROM in the development kit.

For information about the processor, see the NET

Documentation updates
Digi occasionally provides documentation updates

If there are differences between the documentat
documentation on the Web site, the Web site con
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In

tware. If using the Majic debugger instead, 

are.

se the tool set, including:

s, and template applications
troduction

This document provides a series of tasks in which you:

Install Green Hills software.

Install NET+OS software.

Install the Digi JTAG Link debugger software.

Install the license for the Digi JTAG Link debugger sof
instructions are included in several appendixes.

Request and install a license for the Green Hills softw

Configure the IP address for the development board.

Complete a brief exercise that demonstrates how to u

-   Building the board support package (BSP), librarie

-   Running and debugging the sample application

Do the all the tasks in this guide in the order presented.
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T

Ta

Be
in 
tas

Th
ass
ins

ations
tware 
he PC. 
 open 
e 

tive 
n Hills 
lled.

Verify hardware requirements
Verify that the PC is running either 
Microsoft Windows 2000 or XP. 

Windows 95/98/ME and Windows NT 
4.0 are not supported.

What’s next?
Go on to the next task, installing Green 
Hills software.

ours completing the 
time depends on the 
kes to get a license key 
 n  n  n  n  n  n  n

he exercise

sk 1: Getting ready

fore performing the rest of the tasks 
this document several preparation 
ks are necessary.

e instructions in this document 
ume that hardware is already 
talled.

Save files and close applic
The Green Hills and NET+OS sof
installation requires rebooting t
Safe all open files and close any
applications before installing th
software.

Verify access rights
Make sure you have administra
rights on the PC on which Gree
and NET+OS software are insta

Note Plan to spend approximately two h
tasks in this document. The exact 
speed of your PC and how long it ta
from Green Hills. 
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Ta
So

Be
Hil
Gr
htt

W
Wh
ins
sk 2: Install Green Hills MULTI IDE 
ftware

fore installing NET+OS, it is required to install The Green 
ls MULTI IDE version 4.05. This software is available from 
een Hills Software at 
p://www.ghs.com/products/MULTI_IDE.html. 

hat’s next?
en MULTI IDE software is installed, go on to the next task, 
talling NET+OS software.



1

Ta

Th
a w

Ab
Du
nu
on
av

gin the NET+OS installation:

 the installation CD in the CD drive, and follow the 
d prompts.

e Install Method screen, select Advanced Install 
ontinue with the wizard.
6   n  n  n  n  n  n  n

sk 3: Install NET+OS software

is task installs the NET+OS software on your system, using 
izard.

out the installation
ring the installation, if registering NET+OS, a serial-
mber prompt is displayed. Use the serial number located 
 the development board. If the development board is not 
ailable, use Vnnnnnnnn.

To be

1 Place
wizar

2 On th
and c
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3  next?
 next task to obtain a Green Hills license. 
On the Select Development Environment and 
Additional Debuggers page, select Green Hills MULTI 
support for NET+OS. If not using the Digi JTAG Link 
debugger, select the desired debugger. Note that Digi 
ESP for NET+OS is not needed. Then continue following 
the wizard until NET+OS is installed.

What’s
Go to the
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Ta
ke

Th

If 
Gr
Co
pa

he Green Hills license keys
sing the Green Hills MULTI software, request and 

software license key. Request either:

aluation (temporary) key, which allows access to 
reen Hills MULTI software for 30 days.

manent key.

gly recommends requesting both license types at 
 time. An evaluation license key allows immediate 
e software, while acquiring a permanent license key 
up to 15 business days.

I Licensing Wizard creates a license request that can 
led, faxed, or mailed to Green Hills. The wizard 
for information such as:

umber of licenses desired.

her the license is computer-locked or dongle-
d.

ype of computer on which the software is used.

her the license key is an evaluation (temporary) or 
anent license.

se key is sent to your e-mail address.
8   n  n  n  n  n  n  n

sk 4: Request a Green Hills software license 
y

is task requests a license key for the Green Hills software.

upgrading from a prior NET+OS/Green Hills installation, a 
een Hills license is not necessary. Skip to “Task 7: 
nfigure the IP address of the development board” on 
ge 30.

About t
 Before u
install a 

An ev
the G

A per

Digi stron
the same
use of th
can take 

The MULT
be e-mai
prompts 

The n

Whet
locke

The t

Whet
perm

The licen
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Ab
Tw

Co
on

Do
att
lic

ting a license 
 the MULTI icon on the desktop.

ULTI Launcher opens:
out license types
o license types are available:

mputer-locked. A computer-locked license must be used 
 the PC from which the license was requested.

ngle-locked.A dongle-locked license, requires 
aching the dongle to the PC before beginning the 
ense request procedure. 

Reques
1 Click

The M



2

2

ULTI Licensing Wizard opens:
0   n  n  n  n  n  n  n

Because you do not yet have a license, a warning 
pop-up window also opens:

To continue, click OK in the pop-up window.

The M
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3

e MULTI Licensing Wizard, click Request a license 
 Green Hills. Then click Next.
In addition, a warning pop-up window from the 
MULTI License Administrator opens:

To continue, click OK in the pop-up window.

4 In th
from



2

5

icense Request Generator opens with this 

 the form, leaving the GHS User ID (if known) field 
, then click Next.
2   n  n  n  n  n  n  n

This window opens:

Click Create a license request to e-mail, fax, or mail, 
then click Next.

The L
form:

6 Fill in
blank
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7

ck Next.

indow opens:

r License Type, click Evaluation, then click Next.

reen Hills Software 30-day license agreement opens.

w the license agreement, and click Yes.

icense Request Generator window opens.
The License Request Generator window opens:

Do these steps:

a Enter the number of licenses desired.

b Under License Availability, click the type of license 
desired. 

c Do not click Host Managed: license distributed by an 
LM running on this computer.

d Select the computer type.

e Cli

This w

8 Unde

The G

9 Revie

The L
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 License Request Generator does not return a 
of the license request (shown next), stop and 
igi Technical Support. 
4   n  n  n  n  n  n  n

If the License Request Generator window does not 
open, this dialog is displayed:

This message indicates that the dongle was not 
connected. 

Connect the dongle and click Retry in the 
Dongle Not Found dialog.

If the
copy 
call D
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10

11
12
13
14

 next?

 hour, an e-mail message should be received that 

des the license key file and installation instructions.

ates that manual processing is required. Call Digi 
ical Support.

the next task, in which the license key is saved to the 
Review the information in the license request to make 
sure it is correct. Then, do either of these steps:

- If the PC from which the request is made has e-mail, 
click Send.

- If the PC from which the request is made does not 
have e-mail, click Save to File. Go to a system that 
has e-mail and send the request as an attachment to 
license@ghs.com.

In the License Request Generator, click Finish.

In the MULTI Licensing Wizard, click Quit.

Exit from the MULTI Launcher.

To request a permanent license, repeat this task, but at 
step 8, click Permanent for the license type.

What’s

Within an
either:

Inclu

Indic
Techn

Go on to 
PC.
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Ta

Wh
the
sh

 next?
the next task to install the Green Hills license.
6   n  n  n  n  n  n  n

sk 5: Save the license key

en the e-mail message is received from Green Hills, save 
 attachments to a folder on the PC on which the license 

ould be installed. 

What’s
Go on to 
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Ta

Th
e-m

Wh
dir
lau
se

tall the evaluation license key:

le-click the MULTI icon on the desktop.

ULTI Launcher opens:

se you do not yet have a license, this pop-up 
ow opens:
sk 6: Install the Green Hills license key

is task installs the evaluation license key received by 
ail from Green Hills.

en the permanent license is received, follow the 
ections provided by Green Hills with your license. To 
nch the MULTI Licensing Wizard from the MULTI Launcher, 

lect Utilities > License Administrator.

To ins

1 Doub

The M

Becau
wind



2

2

3
4

5

 MULTI Launcher window was not closed, a 
pt is displayed to close all MULTI windows. 
 the other MULTI windows, and click Next in 
ULTI Licensing Wizard.

hoose License File dialog opens:
8   n  n  n  n  n  n  n

To continue, click OK in the pop-up window.

The MULTI Licensing Wizard opens, and this message is 
displayed:

Click OK.

In the MULTI Launcher window, select 
File > Close Launcher.

The MULTI Licensing Wizard remains open.

In the MULTI Licensing window, click Install a license 
which I already have, then click Next.

If the
prom
Close
the M

The C
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6 pdate Licenses window opens:

or messages appear in the Update Licenses window, 
ct Digi Technical Support. Otherwise, click Close.

e MULTI Licensing Wizard, click Quit.

 next?
the next task to configure the development board’s 
s.
Browse to the license file, select it, and click Install.

This window opens:

The installation takes a few minutes. This window 
remains open during the installation process and 
does not require any action.

The U

7 If err
conta

8 In th

What’s
Go on to 
IP addres
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Ta
de

Th
bo

Du
Hy
few

nfigure the IP address of the development board:

e of these steps:

indows XP systems. Select Start > All Programs > 
ET+OS Green Hills > HyperTerminal Connection, 
nd, depending on the port to which the 
evelopment board is connected, either COM1 or 
OM2.

indows 2000 systems. Select Start > Programs > 
ET+OS Green Hills > HyperTerminal Connection, 
nd, depending on the port to which the 
evelopment board is connected, either COM1 or 
OM2.

ot the development board by disconnecting it from 
ower source and reconnecting it.
0   n  n  n  n  n  n  n

sk 7: Configure the IP address of the 
velopment board

is task configures the IP address of the development 
ard.

ring this procedure, be prepared to move quickly to the 
perTerminal window at step 3, because you have only a 
 seconds to respond to the prompt.

To co

1 Do on

- W
N
a
d
C

- W
N
a
d
C

2 Rebo
the p
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3
4

 the default root password, Netsilicon, and press 
. 

irst of a series of configuration prompts 
ars.

ch prompt, do one of these steps:

o accept the current value, press Enter.

o change a setting, enter a value and press Enter.

 scrolling through the settings, a prompt 
ates that you must press a key within five 
ds to change additional settings.

 next?
 Digi JTAG Link debugger, go on to the next section, 
talls the Digi JTAG Link debugger software.

 MAJIC debugger, follow the steps in “Appendix B: 
 IP address for MAJIC debugger” on page 49 and 

ix C: Configure the MAJIC debugger” on page 54.

he Raven debugger, skip to “Task 10: Build the BSP, 
 and applications” on page 36.
This information is displayed in the HyperTerminal 
window:

Press any key within five seconds. 

To change the configuration, press M, then press Enter.

A prompt for a root password is displayed.

5 Enter
Enter

The f
appe

6 At ea

- T

- T

While
indic
secon

What’s
If using a
which ins

If using a
Set up an
“Append

If using t
libraries,
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Ta
lic

est an RDI license for your Digi JTAG Link debugger 
nding email to  

to:license_admin@digi.com" 
e_admin@digi.com

ing the serial number for the JTAG Link and the 
Link RDI request key printed on the card 
ed in your NET+OS Green Hills Supplement 

  If you do not have an RDI request key, you can 
ase a license for the Digi JTAG Link from the 
nline store or a Digi sales distributor (part 
er DG-ACC-RDI-LIC). 

t Start > All Programs > SEGGER > J-Link ARM > J-
RDI Config. 
2   n  n  n  n  n  n  n

sk 8: Install the Digi JTAG Link debugger 
ense

1 Requ
by se

"mail
licens

includ
JTAG
includ
Pack.
purch
Digi o
numb

2 Selec
Link 
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 License.

-Link RDI license management window opens
The J-Link RDI Configuration window opens: 3 Click

The J



3

4

5

6
7

 next?
 next task to configure the Digi JTAG Link debugger.
4   n  n  n  n  n  n  n

Click Add License.

The Add License dialog opens:

Enter the license associated with the serial number on 
the back of the Digi JTAG Link debugger, then click OK. 

The J-Link RDI license management window 
reopens.

Click OK.

The J-Link RDI Configuration window reopens.

What’s
Go to the
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Ta

Th
de

t Start > All Programs > SEGGER > J-Link ARM >  
k RDI Config.

-Link RDI Configuration dialog opens.

 the CPU tab.

r Endian, click Big endian. 

 OK.

 next
ady to build the software. Go on to the next task, 
olves building the BSP, libraries, and sample 
ns.
sk 9: Configure the Digi JTAG Link debugger

is task selects configuration settings for the Digi JTAG Link 
bugger.

1 Selec
J-Lin

The J

2 Click

3 Unde

4 Click

What's
You are re
which inv
applicatio



3

Ta
ap

Th
inc
pro
Wo
Ta

uilding

 file for each platform is used as the main access point 
ng all the libraries, the BSP, and the applications 
for a NET+OS project. 

lding a platform, always open the parent build file for 
orm. From this build file, several tasks are possible, 

ing the entire system.

ating to the application's build file, and building the 
cation.

ating to the BSP platform build file, and building 
SP.
6   n  n  n  n  n  n  n

sk 10: Build the BSP, libraries, and 
plications

is task builds the BSP, libraries, and sample applications, 
luding Hello World, one of the template applications 
vided with NET+OS. This simple application writes Hello 
rld to the HyperTerminal window (which was opened in 

sk 7, step 1).

About b

One build
for buildi
required 

When bui
that platf
including:

Build

Navig
appli

Navig
the B
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Bu
Th

1

2
3

ULTI Project Builder window opens.

e MULTI Project Builder window, select 
> Rebuild ns9360_a.gpj.

uild begins, as shown here:

 the build completes, the BSP, libraries, and all 
ample applications will be built.
ild the entire system
is section uses the NS9360 as an example.

To build the entire system:

To open Green Hills MULTI v4.0.5, double-click the MULTI 
icon on the desktop. 

The MULTI Launcher opens:

Select File > Open Project Builder.

Browse to \netos, and select the platform.

The M

4 In th
Build

The b

When
the s



3

Bu

To 
an

1

2

next
the next task to run and debug the template 
on.
8   n  n  n  n  n  n  n

ild an individual application

rebuild an individual application, select the application 
d select Build, as shown in this example.

Navigate to the template application for the ns9360_a 
platform, as shown here:

Select Build > Rebuild image.

The build occurs and build messages are displayed.

What's 
Go on to 
applicati
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Ta
ap

Th
sec
JTA

If u
de
pa
an
de

 template application using the Digi JTAG 
bugger
 MULTI Project Builder window, select 

g > Debug image. 

indow is displayed:

t Target > Show Connection Organizer.
sk 11: Run and debug the template 
plication

e application is run and debugged in the builder window. This 
tion describes how to debug the application using the Digi 
G Link debugger. 

sing the MAJIC debugger, go to “Appendix D: Run and 
bug the template application with the MAJIC debugger” on 
ge 59.  If using the Raven debugger go to “Appendix E: Run 
d debug the template application with the Raven 
bugger” on page 65.

Run the
Link de
1 In the

Debu

This w

2 Selec



4

3

ew Connection Method window opens:

 Name edit box. enter Jlink.

 the Type pull-down menu, select 
-ICE (rdiserv), then click Create. 
0   n  n  n  n  n  n  n

The Connection Organizer window opens:

Select Method > New.

The N

4 In the

5 From
Multi
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 the folder icon at the end of the line, navigate to 
etos/debugger_files folder, and select the setup 
t (.mbs file) for the target hardware. For most 
 platforms, use ns9xxx_jlink.mbs.

 the Processor pull down menu, select ARM7TDMI or 
TDMI, depending on the processor in use.

lect Little Endian.

 the Advanced tab.
The Multi-ICE (rdiserv) Connection Editor opens: 6 Click
the n
scrip
ARM9

7 From
ARM9

8 Dese

9 Click



4

hese steps:

eck Use RDI DLL.

he input text box next to the Use RDI DLL check 
x contains text, delete it.

ck Choose, navigate to the folder selected as the 
stination for the JLink files, and select JLinkRDI.dll.

the Use RDI DLL check box, replace all back slashes 
 with forward slashes (/).

sing a sub-directory of the Program Files folder, 
ange Program Files to progra~1.

ck Apply.

se the Multi-ICE (rdiserv) Connection Editor by 
cking OK, then close the Connection Organizer 
ndow.

rt the application, in the MULTI Debugger window, 
t Debug > Go. 

re is difficulty connecting, select 
t > Disconnect from Target, then go back to 

10 and continue.
2   n  n  n  n  n  n  n

This dialog opens: 10  Do t

a Ch

b If t
bo

c Cli
de

d In 
(\)

e If u
ch

f Cli

g Clo
cli
wi

11 To sta
selec

If the
Targe
step 
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12

13
14

ntinue execution, select Debug > Go. 

at steps 10 through 13 of this task.

 the breakpoint is reached, the screen looks 
his:

 now completed all the tasks in this exercise.
When the application is loaded and starts running, the 
application dialog appears in the HyperTerminal window. 
Note that Hello World appears in the last line.

Select Debug > Halt. 

At the MULTI> prompt at the bottom of the 
MULTI Debugger window, set a breakpoint at the main 
function by entering:

b main

Then press Enter.

15 To co

16 Repe

When
like t

You have



4

T

He
yo

W
Ad
ex
fun
ex

A g
ap
aft
ap

To
bo

hould my next step be?
 step is running your application from flash. The 
e is broken up into two parts: 

ootloader (rom.bin), located in: 
/src/bsp/platforms/your platform. 

application (image.bin), located in 
/src/examples/your example/32b.
4   n  n  n  n  n  n  n

ips and suggestions

re are some tips for using NET+OS with Green Hills with 
ur own projects. 

here should I put my code, and why? 
d your code as a subdirectory in the c:/netos/src/
amples directory. The software calls the applicationStart 
ction in the root.c file. Start by duplicating some other 

ample and modifying the Makefiles. 

ood choice is naftpapp, the FTP server example. Add your 
plication to this example, which allows reloading new code 
er it is running in flash. Without the FTP server in the 
plication, it is not possible re-flash the system.

 load specific settings, edit the root.c file. To configure 
ard settings, edit the appconf.h file. 

What s
The next
flash cod

The b
netos

Your 
netos
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A mware

Th
MA

Pe
ve

If 
“A
pa

date the MAJIC debugger’s firmware:

 the MAJIC Setup Wizard. Depending on your 
ows operating system, the menu sequence is:

indows XP systems: Select Start > All Programs > 
PI Tools-EDTA > MAJIC Setup Wizard.

indows 2000 systems: Select Start > Programs > 
PI Tools-EDTA > MAJIC Setup Wizard.

PI MAJIC Setup Wizard Introduction window opens:
ppendix A: Update the MAJIC debugger’s fir

is appendix describes how to update the firmware for the 
JIC debugger using the MAJIC Setup Wizard.

rforming this procedure is required if you have a previous 
rsion of the MAJIC firmware.

an IP address of the MAJIC debugger is needed, see 
ppendix B: Set up an IP address for MAJIC debugger” on 
ge 49.

To up

1 Start
Wind

- W
E

- W
E

The E



4

2

 the Choose Update Type pull-down menu, select 
ware update.

click Go.
6   n  n  n  n  n  n  n

Review the introduction and click NEXT.

The Choose Operation window opens: 3 From
Firm

Then 
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4

AJIC Connection Parameters dialog opens:

ese steps:

ck I will be using an Ethernet IP address to 
mmunicate with my MAJIC. 

ter the IP address for the MAJIC.

ke sure Use My Static IP address is selected.

 click Update.
The MAJIC Firmware Update Installer dialog opens:

If the directory name is not already in the 
Location of update files input box, browse to this 
directory:

C:\ProgramFiles\EPITools\edta22A\ice\majic

and click NEXT.

The M

5 Do th

a Cli
co

b En

c Ma

Then



4

6

 the download finishes, do one of these steps:

f the download was successful, click OK in the 
heck Your Installation Result dialog.

f the download was not successful, click Cancel in 
he Check Your Installation Result dialog, and 
epeat this procedure.
8   n  n  n  n  n  n  n

The Install Update dialog opens:

To begin the update, click OK.

A DOS window and the Check Your Installation 
Result dialog open. Messages about the firmware 
download are displayed in the DOS window:

7 When

- I
C

- I
t
r
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A ebugger

Th
de

Yo

 

 

t up the IP address of the MAJIC debugger:

 the serial cross cable that ships with the MAJIC, 
ct the MAJIC to an available COM port on your PC. 

re is not an available connection on your PC, 
 the one already connected to the development 
. In this case, close all applications associated 
the COM port, such as HyperTerminal.

 the MAJIC Setup Wizard. Depending on your 
ows operating system, the menu sequence is:

indows XP systems: Start > All Programs > EPI 
ools-EDTA > MAJIC Setup Wizard.

indows 2000 systems: Start > Programs > EPI 
ools-EDTA > MAJIC Setup Wizard.
ppendix B: Set up an IP address for MAJIC d

is section describes how to set up an IP address for the MAJIC 
bugger. 

u must follow the instructions in this section if:

You are a new user.

You are upgrading and do not know the IP address of your 

MAJIC debugger.

To se

1 Using
conne

If the
reuse
board
with 

2 Start
Wind

- W
T

- W
T
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3

hoose Operation window opens:

 the Type of Connection pull-down menu, select 
c IP Address for Ethernet, then click Go.
0   n  n  n  n  n  n  n

The EPI MAJIC Setup Wizard Introduction window 
opens:

Click NEXT.

The C

4 From
Stati
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5

AJIC Connection Parameters window opens:

ese steps:

ck I will be using a serial port to communicate with 
 MAJIC. 

m the COM port to use pull-down menu, select the 
ial port number. 

ke sure no other programs are using the COM port 
lected.

ck Install IP.
The Configure MAJIC’s Ethernet Static IP Address 
window opens:

Enter this network information:

- IP Address

- Subnet Mask

- Default Gateway

then click NEXT.

The M

6 Do th

a Cli
my

b Fro
ser

c Ma
se

d Cli
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7

8

9

10

 DOS window, ping the IP address by entering:

ip address

 ip address is the IP address of the MAJIC.

OS window looks like this:

colors of the text and background are reversed 
s screen for easier reading.)

 ping succeeds, the IP address is installed.

 fwo o setup ; do tv_ipx

= VALUE DESCRIPTION

_ip_address

_ip_netmask

_ip_gateway

q y
= 255.255.248.0

= 10.52.32.1

// Static IP address for target

// Subnet mask for target

// Static gateway IP address for 

ogram Files \EPITools\edta21\bin>ping 10.52.32.135

 from 10.52.32.135: bytes=32 time=1ms TTL=254
 from 10.52.32.135: bytes=32 time=1ms TTL=254

 from 10.52.32.135: bytes=32 time=1ms TTL=254

 from 10.52.32.135: bytes=32 time=1ms TTL=254

statistics for 10.52.32.135:

ackets: Sent = 4. Received = 4. Lost = 0 (0% loss).
ximate round trip times in milli-seconds:

inimum = 1ms. Maximum = 1ms. Average = 

ram Files\EPITools\edta21\bin>

= 10.52.32.135

ng 10.52.32.135 with 32 bytes of data:

ring output into setip.out

ME
2   n  n  n  n  n  n  n

The Install Static IP dialog opens:

Connect the MAJIC serial cable between the MAJIC 
debugger’s serial port and the COM port selected in the 
MAJIC Connection Parameters window (in step 6 of this 
task), and then click OK.

A dialog and a DOS window open.

In the Check Your Installation Result dialog, confirm 
that the IP address information in the DOS window is 
correct by clicking OK.

If there is a problem, correct it and go back to step 
1 of this task.

Connect an Ethernet cable from the MAJIC debugger to 
the LAN hub or switch.

After the MAJIC debugger turns off, power-cycle the 
MAJIC.

11 In the

ping 

where

The D

(The 
in thi

If the

MON>

eo tv

eo tv

eo tv

eo : 

C:\Pr

Reply
Reply

Reply

Reply

Ping 

P
Appro

M

C:\Prog

Pingi

Captu

// NA
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12
13
If this response is not displayed:

- Check the Ethernet connection to the MAJIC.

- Confirm that the IP parameters are legal.

- Verify that the MAJIC was power-cycled.

Otherwise, repeat this task.

Close the DOS window.

In the Check Your Install Results dialog, click OK.



5

A

Th
usi

re the MAJIC debugger:
 the MAJIC Setup Wizard. Depending on your 
ws operating system, the menu sequence is:

indows XP systems: Start > All Programs > 
PI Tools-EDTA > MAJIC Setup Wizard.

indows 2000 systems: Start > Programs > 
PI Tools-EDTA > MAJIC Setup Wizard.
4   n  n  n  n  n  n  n

ppendix C: Configure the MAJIC debugger

is task configures software settings for the MAJIC debugger, 
ng the EPI MAJIC Setup Wizard.

Configu
1 Start

Windo

- W
E

- W
E
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2

hoose Operation window opens:

 the Choose Your Debugger pull-down menu, select 
ompliant Debugger, and click Go.
The EPI MAJIC Setup Wizard Introduction window 
opens:

Review the introduction and click NEXT.

The C

3 From
RDI C
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4

PU Configuration window opens:

ese steps:

m the Select Your Processor Type pull-down 
nu, select ARM926EJS.

der Select your Target’s Endianness, click 
Endian. Under Startup Connection Mode, click 
trusive Mode (reset and stop processor).

ck NEXT.
6   n  n  n  n  n  n  n

The Project Name window opens:

Create a new project by entering a project name and a 
brief description. Then click NEXT.

The C

5 Do th

a Fro
me

b Un
Big
Ins

c Cli
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6

onfiguration Files window opens:

 Use Existing Startup File, and do these steps: 

ck Browse.

vigate to Program Files > EPI Tools > edta22a > 
rgets > ns9xxx directory.

lect the file startice.cmd, and click Open. 

ck NEXT.
The MAJIC Connection Parameters window opens:

Do these steps:

a Click I will be using an Ethernet IP address to 
communicate with my MAJIC.

b Enter the IP address for the MAJIC. Use the IP address 
provided in Task 8, step 6.

c Make sure Use My Static IP address is selected.

d Click NEXT.

The C

7 Click

a Cli

b Na
Ta

c Se

d Cli
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8

erform Setup window displays a summary of the 
tions:

k Enabled for each item, then click 
rm Actions. This step creates MAJIC setup files in 
irectory specified in step 8. 

 directory does not exist, the MAJIC Setup Wizard 
ys a pop-up warning to create one. Click Yes to 
e the directory.

it the wizard, click Done.
8   n  n  n  n  n  n  n

The Destination Directory window opens:

Click Select a Destination Directory to Create/Copy
Startup Files to.

Browse to the directory to use for files that are 
created or copied during the MAJIC setup.

Make sure that each name in the path is eight 
characters or fewer and does not use any spaces. 

Then click NEXT.

The P
selec

9 Chec
Perfo
the d

If the
displa
creat

10 To ex
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A cation with the MAJIC debugger

Th

1

t Target > Show Connection Organizer.
ppendix D: Run and debug the template appli

is task shows how to run an application with MAJIC debugger.

To run the template application using the MAJIC 
debugger:

In the MULTI Project Builder window, select 
Debug > Debug image.

This window is displayed:

2 Selec



6

3

reate New Connection Method dialog opens:

ese steps:

the Name input box, enter ns9xxx (for either the 
360_a or ns9750_a platform).

m the Type pull-down menu, select ARMulator 
iserv) for ARM.

ick Create.
0   n  n  n  n  n  n  n

The Connection Organizer window opens:

In the User Methods section of the window, right-click 
as noted in the illustration, and select New.

The C

4 Do th

a In 
ns9

b Fro
(rd

c  Cl
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e Connection portion of the Armulator window, do 
 steps:

om the Processor pull-down menu, select 
M9TDMI. (This option is compatible with the 
t+Silicon ARM926EJS-based processors.)

select Little Endian. 

ck the Advanced tab.
The ARMulator (rdiserv) Connection Editor opens: 5 In th
these

a Fr
AR
Ne

b de

c Cli



6

ese steps:

lect RDI DLL.

he input text box next to the RDI DLL check box 
ntains text, delete it.

ck Choose, navigate to the folder selected as the 
stination for the EPI files (in Task 9, step 8), and 
ect rdimajic.dll. 

the Use RDI DLL text box, replace the back slashes 
 with forward slashes (/).

ck Apply.

 the ARMulator (rdiserv) Connection Editor by 
ng OK, then close the Connection Organizer 
ow.

yperTerminal window is not open, open one as 
cted in Task 7, step 1.

 MULTI Debugger window, select Target > Connect.
2   n  n  n  n  n  n  n

This information is displayed in the center of the 
window:

6 Do th

a Se

b If t
co

c Cli
de
sel

d In 
(\)

e Cli

7 Close
clicki
wind

8 If a H
instru

9 In the
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10

11

 the program is loaded and starts to run, the sample 
cation dialog appears in the HyperTerminal window. 
 that Hello World appears in the last line of code.

t Debug > Halt. 

e MULTI> prompt at the bottom of the 
I Debugger window, set a breakpoint at the main 
ion by entering: 
n

The Connection Chooser dialog opens:

Check that the target name matches the name entered 
in step 4a, and click Connect. 

In the MULTI Debugger window, select Debug > Go to 
start running the program. 

If there is any difficulty connecting, select 
Target > Disconnect, then go back to step 7.

When
appli
Note

12 Selec

13 At th
MULT
funct
b mai
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14

15
4   n  n  n  n  n  n  n

Select Target > Disconnect from Target, and repeat 
steps 7 through 10.

When the breakpoint is reached, the screen looks 
like this:

To continue execution, select Debug > Go.
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A ication with the Raven debugger

1 t Target > Show Connection Organizer.

onnection Organizer window opens:
ppendix E: Run and debug the template appl

In the MULTI Project Builder window, select 
Debug > Debug image.

The window looks like this:

2 Selec

The C



6

3

4

acraigor OCD (ocdserv) Connection Editor 
s:
6   n  n  n  n  n  n  n

In the User Methods section of the window, right-click 
and select New.

The Create New Connection Method dialog opens:

Do these steps:

a In the Name input box, enter a descriptive name for 
the platform.

b From the Type pull-down menu, select Macraigor OCD 
(ocdserv) for ARM.

Then click Create.

The M
open
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5

6

e MULTI Debugger, select Target > Connect.

onnection Chooser dialog opens:

k that the target name matches the name entered 
p 4a.

e Connection Chooser dialog, click Connect. 

e MULTI Debugger window, select Debug > Go to 
 running the program. 

re is difficulty connecting, select 
t > Disconnect, then go back to step 7.
In the Macraigor OCD (ocdserv) Connection Editor, do 
these steps:

a In the input box next to Target Setup script, navigate 
to the netos\debugger_files\ directory, and select the 
script for the platform. The scripts have a .mbs 
extension.

b In the Local section, click Raven. Then, from the 
Parallel Port pull-down menu, select the parallel port 
for the local connection.

c In the Processor section, from the Processor pull-
down menu, select NetARM. From the Endian pull-
down menu, select Big.

Click Apply.

Click OK to close the Macraigor OCD (ocdserv) 
Connection Editor, then close the Connection Organizer 
window.

7 In th

The C

8 Chec
in ste

9 In th

10 In th
start

If the
Targe



6 8

11

t Target > Disconnect from Target, and repeat 
 7 through 10. When the breakpoint is reached, the 
n looks like this:

ntinue execution, select Debug > Go.
  n  n  n  n  n  n  n

When the program is loaded and starts running, the 
sample application dialog appears in the HyperTerminal 
window, as shown here. Note that Hello World appears 
in the last line of the window.

Select Debug > Halt. 

At the MULTI> prompt at the bottom of the MULTI 
Debugger window, set a breakpoint at the main function 
by entering: 

b main

12 Selec
steps
scree

13 To co
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