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Digi ConnectCore Smart IOmux Release Notes 

Digi ConnectCore Smart IOmux 

Version 2.1.0 (May 3, 2023) 

INTRODUCTION 

These are the release notes for Digi ConnectCore Smart IOmux, the tool that simplifies the pin 
configuration and resolution of Digi International Inc. ConnectCore modules. 

SUPPORTED PRODUCTS 

Operating systems 

 Windows Vista/7/8/10 (32-bit or 64-bit versions) 

 

ConnectCore platforms 

 Digi ConnectCore 6UL 

 Digi ConnectCore 8X 

 Digi ConnectCore 8M Nano 

 Digi ConnectCore 8M Mini 

 Digi ConnectCore MP157 

 Digi ConnectCore MP133 (beta) 

 Digi ConnectCore 93 (beta) 

KNOWN ISSUES 

1. The keyboard (KPP) component does not allow line selection. All lines are enabled by default. 

2. The CCMP133 and CC93 platforms are still under development, so there may be some missing 

device tree parts and unknown default values. Some components and pad configurations may 

change in a future revision. 

UPDATE CONSIDERATIONS 

N/A 

UPDATE BEST PRACTICES 

There are two ways of getting this new version: 

1. If you do not have Smart IOmux installed on your computer, download and install the tool 
from the Digi website (https://www.digi.com/products/embedded-systems/system-on-

http://www.digi.com/
https://www.digi.com/products/embedded-systems/system-on-modules/connectcore-for-i-mx6ul
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modules/connectcore-for-i-mx6ul). 

2. If you already have Smart IOmux installed on your computer, open the tool and wait until it 
notifies you about the new update. Then, follow the process to install the new version. 

You can manually check for updates at any time from Help > Check for updates. 

 

You should always run the latest version of Smart IOmux. 

TECHNICAL SUPPORT 

Get the help you need via our Technical Support team and online resources. Digi offers multiple 

support levels and professional services to meet your needs. All Digi customers have access to 
product documentation. firmware, drivers, knowledge base and peer-to-peer support forums.  

Visit us at https://www.digi.com/support to find out more. 

CHANGE LOG 

VERSION 2.1.0 (May 3, 2023) 

This is a mandatory release. 

NEW FEATURES 

1. Added support for ConnectCore 93 platform (beta). [IOMUX-315, IOMUX-334] 

2. Added support to change the base platform of a compatible design. [IOMUX-340] 

ENHANCEMENTS 

1. N/A 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed an issue to only reset IOmux values when changing their associated pad. [IOMUX-312] 

2. Fixed the resolution algorithm to properly exclude non-compatible IOmux configurations of 

compatible designs. [IOMUX-340] 

3. Fixed issue that was displaying checkboxes for fixed pads in the configuration view. [IOMUX-

335] 

VERSION 2.0.1 (March 24, 2023) 

This is a mandatory release. 

NEW FEATURES 

1. Added support for ConnectCore MP133 platform (beta). [IOMUX-243, IOMUX-281, IOMUX-316] 

2. Added support for kernel 5.15 on ConnectCore 8M Mini, ConnectCore 8M Nano and 

ConnectCore 6UL platforms.[ IOMUX-318] 

3. Added conflicts detector dialog to identify unsolvable designs when loading them into the 

tool. This dialog shows conflicts between pads and resources of components and allows to 

attempt an automatic fix when possible. [ IOMUX-325] 

https://www.digi.com/products/embedded-systems/system-on-modules/connectcore-for-i-mx6ul
https://www.digi.com/support
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ENHANCEMENTS 

1. N/A 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed an issue with the Ethernet RMII mode in the CC8MM platform. [IOMUX-314] 

2. Fixed some pads that changed in v2 of the CC8MM and CC8MN SOMs. [IOMUX-260] 

3. Fixed handling of collapsible panes in the component configuration view. [IOMUX-332] 

4. Fixed issue with ADC component not adding the pinctrl section to the device tree in 

ConnectCore 8X and ConnectCore 6UL platforms. [IOMUX-330] 

5. Added minor updates to device tree hints and components in ConnectCore MP157 platform. 

Updated the DVK template to account for these changes. [IOMUX-321] 

VERSION 2.0.0 (October 20, 2022) 

This is a mandatory release. 

NEW FEATURES 

1. Added support for ConnectCore MP157 platform (beta). [IOMUX-237, IOMUX-238, IOMUX-239, 

IOMUX-240, IOMUX-275, IOMUX-277, IOMUX-280] 

2. Added a new way to create designs compatible with other ConnectCore platforms, organized 

in two different families: CC6UL/CCMP157 and CC8X/CC8MM/CC8MN. This replaces the existing 

compatible pinout functionality. [IOMUX-262, IOMUX-264, IOMUX-265, IOMUX-267, IOMUX-274, 

IOMUX-278, IOMUX-279] 

3. Added a new graphic view to quickly visualize free, used and reserved pads of the module. 

[IOMUX-241, IOMUX-244, IOMUX-245, IOMUX-246, IOMUX-247, IOMUX-248, IOMUX-255, IOMUX-

256, IOMUX-257, IOMUX-261, IOMUX-263] 

4. Added new MCA components to several platforms (LED, tamper and keypad). [IOMUX-290, 

IOMUX-291, IOMUX-292] 

5. Added a new home view with information about the platform and the design itself. [IOMUX-

301] 

ENHANCEMENTS 

1. Changed the style, icons and fonts of the application. [IOMUX-272, IOMUX-273, IOMUX-294, 

IOMUX-301] 

2. Improved the resolution algorithm with new prunes in the process. [IOMUX-299] 

3. Added missing pads to the USB 3.0 component of the ConnectCore 8X platform. [IOMUX-229] 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Removed pads T_29 and U_29 from castellated designs in the ConnectCore 8M Mini and 8M 
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Nano platforms. [IOMUX-253] 

2. Removed MCA pads 11, 12 and 18 as ADC capable in the ConnectCore 8X, 8M Mini and 8M Nano 

platforms. [CC8M-79] 

3. Fixed an issue with the --prefix argument in the CLI installer. [IOMUX-260] 

VERSION 1.9.2 (February 24, 2022) 

This is a mandatory release. 

NEW FEATURES 

1. N/A 

ENHANCEMENTS 

1. Improved the resolution algorithm with new prunes in the process [IOMUX-234]. 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed an issue that was blocking a few pads of a design limiting the total number of free pads 

[IOMUX-235]. 

VERSION 1.9.1 (December 14, 2021) 

This is a mandatory release. 

NEW FEATURES 

1. N/A 

ENHANCEMENTS 

1. N/A 

SECURITY FIXES 

1. Updated log4j library to fix CVE-2021-44228 vulnerability 

BUG FIXES 

1. N/A 

VERSION 1.9.0 (March 25, 2021) 

This is a recommended release. 

NEW FEATURES 

1. Added support for ConnectCore 8M Mini platform (beta). [IOMUX-222] 

2. Included ConnectCore 8M Mini platform in the SMT Plus 40x45 layout. [IOMUX-223] 

3. Added support for CC8M Nano 0x02 (No WiFi/Bluetooth) variant. [IOMUX-224] 

ENHANCEMENTS 

1. Added muxes corresponding to pads K_29 and AG_25 to the CC8MN platform. [IOMUX-228] 

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44228
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SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed an issue with a duplicated pad in the CC6UL SBC Pro templates. [DEL-7390] 

2. Fixed an issue with default template components when switching the platform or removing 

the compatibility of a cross-platform design. [IOMUX-227] 

VERSION 1.8.2 (December 23, 2020) 

This is a recommended release. 

NEW FEATURES 

1. N/A 

ENHANCEMENTS 

1. N/A 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed some issues in the CC8X and CC8MN templates [IOMUX-220]. 

VERSION 1.8.1 (November 27, 2020) 

This is a recommended release. 

NEW FEATURES 

1. Added the possibility to cancel the load of designs that have compatibility issues. 

ENHANCEMENTS 

1. Added some missing resources and fixed some issues related to cross-platform projects 

[IOMUX-211]. 

2. Added LPSPI1 resource to CC8X platform and kernel 5.4 [IOMUX-209]. 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed the electrical value documentation of some CC8X pads [IOMUX-212]. 

2. Updated the documentation of SPI component for CC8X and CC8MN platforms to remove the 

chip select note [IOMUX-214]. 

3. Removed the warning that appears for an invalid electrical value if that value is the default one 

[IOMUX-208]. 

VERSION 1.8.0 (July 21, 2020) 

This is a recommended release. 
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NEW FEATURES 

1. Added support for cross-platform designs. [IOMUX-142, IOMUX-177, IOMUX-178] 

2. Added a search box in the components table view. [IOMUX-67] 

3. Added support for kernel version 5.4. [IOMUX-201] 

ENHANCEMENTS 

1. Added MIPI DSI component to the CC8X platform. [IOMUX-191] 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed a couple of issues during the “Save as” process of a design. 

VERSION 1.7.0 (February 5, 2020) 

This is a recommended release. 

NEW FEATURES 

1. Added support for ConnectCore 8M Nano platform (beta). [IOMUX-169] 

ENHANCEMENTS 

1. N/A 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed some backward compatibility issues. [IOMUX-168, IOMUX-167, IOMUX-165, IOMUX-166] 

VERSION 1.6.0 (October 30, 2019) 

NEW FEATURES 

1. Added support for multiple kernel versions. [IOMUX-160] 

ENHANCEMENTS 

1. Updated several components and their device trees. 

2. Added a mechanism to warn the user about the required device tree customizations. [IOMUX-

140] 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed some backward compatibility issues. [IOMUX-117, IOMUX-134] 

VERSION 1.5.0 (May 31, 2019) 
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NEW FEATURES 

1. N/A 

ENHANCEMENTS 

1. Added some missing device trees and default values of the CC8X and CC6UL platform. 

2. Added new components for the CC8X platform and CC6UL. 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. N/A 

VERSION 1.4.0 (December 7, 2018) 

NEW FEATURES 

1. Display the components' reserved pads in addition to the IOmuxes. 

ENHANCEMENTS 

1. Added some missing device trees and default values of the CC8X platform. 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. N/A 

VERSION 1.3.0 (September 10, 2018) 

NEW FEATURES 

1. Added support for ConnectCore 8X platform (beta). 

ENHANCEMENTS 

1. N/A 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed an issue when loading old designs that are not compatible with the latest versions of the 

tool. 

VERSION 1.2.0 (July 7, 2018) 

NEW FEATURES 

1. Device tree. 

Digi ConnectCore Smart IOmux is now able to export the complete device tree of a design. This 
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can be done from the Export option of the toolbar and the File > Export > Export Device tree 

menu entry. 

Device tree hints tab has been renamed to Device tree. List of components within this tab are 

now hanging from a root element that represents the design. If you click this element, the 

device tree view displays the complete device tree of the design. If you click any other 

component, the view displays just the device tree block associated to that component. 

2. Electrical configuration. 

Electrical configuration of IOmuxes can be performed in a new dialog. It contains detailed 

information about the value of each bit that composes the configuration register of the IOmux. 

This configuration dialog can be accessed from each IOmux configuration panel. 

3. Provide feedback. 

This version of the application includes the possibility to provide us with your feedback about 

the application itself through the Provide feedback dialog. It can be accessed directly from the 

toolbar or from the Help > Provide feedback menu entry. 

4. Change log. 

Added a Change log dialog that lists all the Digi ConnectCore Smart IOmux releases with the 

new features, changes and fixes they introduce. This dialog is displayed automatically 

whenever the application is installed from scratch or it has been updated to a new version. It is 

also possible to open the change log dialog from the Help > Change log menu entry. 

ENHANCEMENTS 

1. MX6UL_PAD_NAND_DQS pad (M_2) of the CC6UL platform is no longer locked. 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Castellated pad names are now displayed correctly in the Table view of the design. 

VERSION 1.1.1 (May 29, 2018) 

NEW FEATURES 

1. N/A 

ENHANCEMENTS 

1. Reordered swapped USB indexes. 

2. Removed GPIO5_IO03 resource since it is not routed in the SOM. 

SECURITY FIXES 

1. N/A 

BUG FIXES 

1. Fixed mismatched UART labels. 

2. Fixed wrong pad for Ethernet reset (ETH1 RST) when using the CC6ULSBC PRO template. 

VERSION 1.0.0 (August 8, 2017) 
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First release of Digi ConnectCore Smart IOmux. 

 


