
96000472_C   Release Notes Part Number: 93001315_L 

  Page 1 

DIGI INTERNATIONAL 

9350 Excelsior Blvd, Suite 700 
Hopkins, MN 55343, USA 

+1 (952) 912-3444 | +1 (877) 912-3444 

www.digi.com 

 
 

 

 Software Release Notes 

AnywhereUSB Manager for Microsoft Windows 

Version 10.1.28.178 (July 7, 2022) 

INTRODUCTION 

These are the release notes for AnywhereUSB Manager for Microsoft Windows. 

 

AnywhereUSB® Plus is a Remote USB 3.1 Hub that implements USB over IP® technology over Gigabit 

Ethernet networks. The Hub enables communication with USB-enabled devices from virtualized 

systems and from remote host computers. You can securely deploy AnywhereUSB® Plus Remote 
USB 3.1 Hubs in non-secure environments, making it ideal for point-of-sale, kiosks, surveillance, 
industrial automation, or any mission-critical enterprise application. This Gigabit Ethernet-attached 

solution provides 2, 8, or 24 USB 3.1 ports to connect a wide range of peripheral devices such as 
USB license dongles, scanners, printers, cameras, storage media, or other  

USB devices. The 8- and 24-port models provide support for 10 Gigabit Ethernet and include SFP+ 
interfaces. 

 

To install, run the Microsoft Windows Installer and follow prompts.  Remember there are different 
installers for 32-bit and 64-bit Microsoft Windows operating systems. 

 

The AnywhereUSB Manager supports the AnywhereUSB Plus family of products:  

 AnywhereUSB 2 Plus 

 AnywhereUSB 8 Plus  

 AnywhereUSB 24 Plus 

 

The earlier AnywhereUSB products (AnywhereUSB 2, AnywhereUSB 5/5M, AnywhereUSB 14, and 

AnywhereUSB TS/44) use a different driver package. For more information, please refer to the 
AnywhereUSB product page. 

SUPPORTED PRODUCTS 

 AnywhereUSB Manager for Microsoft Windows for 32-bit operating systems. 

 AnywhereUSB Manager for Microsoft Windows for 64-bit operating systems. 

  

http://www.digi.com/
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SUPPORTED Operating systems 

 Microsoft Windows 7 

 Microsoft Windows 8.1 

 Microsoft Windows 10 

 Microsoft Windows Server 2012-R2 

 Microsoft Windows Server 2016 

 Microsoft Windows Server 2019 

KNOWN ISSUES 

To uninstall the AnywhereUSB Manager: 

 The AnywhereUSB Manager must be uninstalled from the Control Panel using 

"Programs and Features.”   

 From “Programs and Features” select the Digi AnywhereUSB Manager then select 

“Change” 

 When the window opens click “Next” 

 On the "Program Maintenance" window select “Remove" and click “Next” 

 If you wish to remove your configuration, you can check "Remove User Configuration" 

and click "Next". 

MANAGER UPDATE PROCEDURE  

The following procedure must be used to update to this version of the Manager:   

1. If an earlier version of the AnywhereUSB Manager is currently installed on your PC, 

uninstall it as follows: 

 Open the Control Panel and select "Programs and Features”   

 From “Programs and Features” select the Digi AnywhereUSB Manager then select 

“Change” 

 When the window opens click “Next” 

 On the "Program Maintenance" window select “Remove" and click “Next” 

 Make sure the "Remove User Configuration" is not checked and click "Remove", 

this will preserve your current configuration.  

2. Now you can install the Digi AnywhereUSB Manager update. 

TECHNICAL SUPPORT 

Get the help you need via our Technical Support team and online resources. Digi offers multiple 

support levels and professional services to meet your needs. All Digi customers have access to 
product documentation, firmware, drivers, knowledge base, and peer-to-peer support forums.  

Visit us at https://www.digi.com/support to find out more. 

 

 

https://www.digi.com/support
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CHANGE LOG 

VERSION 10.1.28.178 (July 7, 2022) 

Installer version  10.1.28.178 

Manager version  3.1.26.1 

Driver version  7.1.3.108 (Microsoft Windows 10, Server 2016, and Server 2019) 

Driver version  7.1.2.107 (Microsoft Windows 7, 8.1, and Server 2012-R2) 
 

Software Packages P/N’s 

40003044 (32-bit)   

MD5:  a72b76eb4f4ee8f1da3a359161dccd54  

SHA256:  cdd104b2258399b1770677968a87fe073ddc9b423d49a59ba3081ea20a78bfdb 

 

40003045 (64-bit) 

MD5:  3b1f0fed00d4bb032a35ff3feb42b1c6 

SHA256:  0d7c975883c9897314c09c40a5048ab0346e43ce400fa31cf0adcc6e8020b7fe 

 

NEW FEATURES 

 [AWG3-2620, AWG3-2746, AWG3-2861] 

Applies only to Windows 10, Server 2016, Server 2019, and newer. 

Add a feature to assign USB devices connected to an AnywhereUSB Hub to particular 

virtual host controller ports.  This has the effect of forcing a particular device to a fixed USB 

path on a Windows PC. This feature can be used to avoid COM port renumbering, 

reordering of multiport devices or other USB device naming issues across PC and/or Hub 

restarts. After assigning USB devices, restart PC for assignments to become active. 

ENHANCEMENTS 
 Improvements to support file and logging. 

SECURITY FIXES 
 None. 

BUG FIXES 
 None. 
 

VERSION 10.1.26.176 (November 4, 2021) 

Installer version  10.1.26.176 

Manager version  3.1.23.1 

Driver version  7.1.2.107 (Microsoft Windows 10, Server 2016, and Server 2019) 

Driver version  7.1.2.107 (Microsoft Windows 7, 8.1, and Server 2012-R2) 

NEW FEATURES 

 None. 

ENHANCEMENTS 
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 None. 

SECURITY FIXES 
 None. 

BUG FIXES 
 [AWG3-2745, AWG3-2793]  Fix network connection and disconnect issues in the Manager.   

Restructured the secure network communication layer to improve connection robustness.  
Environments with unexplained network disconnect messages in the Manager logs may 
benefit from this fix. 

 

VERSION 10.1.24.174 (June 17, 2021) 

Installer version  10.1.24.174 

Manager version  3.1.22.1 

Driver version  7.1.2.107 (Microsoft Windows 10, Server 2016, and Server 2019) 

Driver version  7.1.2.107 (Microsoft Windows 7, 8.1, and Server 2012-R2) 

NEW FEATURES 

 [AWG3-2557] Display “PORT ON HUB” for each device. This indicates the front panel port 

number where the device is attached, either directly or through one or more downstream 

USB hubs. For example, a USB device connected to port 3 of a 4-port downstream hub 

connected to port 7 of an AW08, will show “PORT ON HUB: 7”. 

ENHANCEMENTS 
 [AWG3-2725] Improve power control implementation in Manager.  Power cycle off time now 

defaults to 3 seconds; previously too short at 1 second.  Add Power cycle off time 

configuration in File->Preferences Advanced tab.  Use same underlying implementation of 
power control as WebUI, for consistency of operation. 

 [AWG3-2730] Enforce minimums for certain configuration items.  Ensure that minimums are 

enforced for config items in File->Preferences Advanced tab.  This limits cpu/memory 
runaway of the Manager if timeouts are too short.  Config items are set to minimum if value 

is lower than minimum. 

 Add informational messages in Microsoft Windows event log when service starts and stops. 

SECURITY FIXES 
 [AWG3-2662] Update Manager to OpenSSL 1.1.1k 

BUG FIXES 
 Fix System Messages window in service mode.  In service mode, the System Messages 

window, if visible, was pulled to the top and given focus when the log messages updated.  
Now the behavior matches standalone mode, where the messages are updated but the 
window is not pulled to the top.  

 [AWG3-2695] Fix Power Cycle Device menu item when running in service mode. 

 [AWG3-2492] Fix local naming on reconnect.  Manager local naming of USB devices without 
device serial numbers was previously not working properly after disconnect and reconnect 

to a Hub or on Manager restart. 
  
 

VERSION 10.1.23.171 (February 23, 2021) 



96000472_C   Release Notes Part Number: 93001315_L 

  Page 5 

Installer version  10.1.23.171 

Manager version  3.1.21.1 

Driver version  7.1.2.107 (Microsoft Windows 10, Server 2016, and Server 2019) 

Driver version  7.1.2.107 (Microsoft Windows 7, 8.1, and Server 2012-R2) 

NEW FEATURES 
None 

ENHANCEMENTS 
 Increase Manager keep alive timeout for connection robustness 

 Log improvements: 

o The entire AnywhereUSB Manager system log is now copied to the clipboard 
o In previous releases it only collected the most recent messages 

 Compression and Encryption speed improvements 

 [AWG3-2567] Added a feature to the Help Menu:  “Create Support File” 

  [AWG3-2560] Added a checkbox to decrease hub discovery time. “Use All Hub Addresses ” 

The AnywhereUSB Plus Hubs provide multiple default IPV4 addresses in addition to the 
primary IP addresses. These extra IPV4 addresses are used for configuration and other 

purposes and may not allow the Manager to connect to the Hub. The discovery process will 
report all of the IPV4 addresses to the manager.  By default, this checkbox is unchecked, 

thus ignoring the extra addresses. If checked, the Manager will attempt to connect using all 

Hub addresses provided which will slow the connection to Hubs due to round-robin cycling 
through all the extra IP addresses. 

 [AWG3-2492] Use address for Local Name if USB device does not have a USB serial number 
If a device does not contain a USB serial number, and you assign a Local Name, It will use the 
USB address of the device to distinguish identical devices. 

 [AWG3-2325] Added feature to Hub Right Click Menu  “Add to Known Hubs”  

 [AWG3-2428, AWG3-2298, AWG3-2239] 
o Add power cycle action to device menu and CLI command: POWER CYCLE,address 

 [AWG3-2382, AWG3-2541]   Add SET CLIENTID command to CLI 
o This is to assist with silent install of the driver. 

SECURITY FIXES 
 AWG3-2608: TLS Cipher cleanup 2020 

o Remove insecure ciphers from AnywhereUSB connections 

 AWG3-2309: Update Manager to openssl 1.1.1i 

BUG FIXES 
    [AWG3-2636, AWG3-2199] Fix hang if driver is not available.  

 

VERSION 10.1.22.170 (November 13, 2020) 

Installer version 10.1.22.170 

Manager version 3.1.20.1 

Driver version  7.1.2.107 (Microsoft Windows 10, Server 2016, and Server 2019) 

Driver version  7.1.2.107 (Microsoft Windows 7, 8.1, and Server 2012-R2) 

NEW FEATURES 
None 

ENHANCEMENTS 
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 Added Always On Top checkbox in help menu 

 Removed latency graph in service mode: (AWG3-2568, AWG3-2569) 

 Improved Manager logging feature 

 Improved USB Isochronous support 

SECURITY FIXES 
None 

BUG FIXES 
Fix a device driver bug where a USB device would enumerate but would not transfer data. (AWG3-
2510) 

 

VERSION 10.1.21.168 (September 28, 2020) 

Installer version 10.1.21.168 

Manager version 3.1.19.1 

Driver version 7.1.1.105 (Microsoft Windows 10, Server 2016, and Server 2019) 

Driver version 7.1.0.106 (Microsoft Windows 7, 8.1, and Server 2012-R2) 

NEW FEATURES 
None. 

ENHANCEMENTS 

 AWG3-2476 Improve keep alive to not to inadvertently disconnect connections 

 System Logging: 

 Add additional System Messages 

 Log System Messages to file by default in service and standalone modes 

 Create larger System Messages window when opened 

 Remove oldest System Messages to keep memory usage low 

 Update System Messages window when service is running 

 

 Service vs Standalone: 

 AWG3-2524 If Manager is installed in service mode, the service must be started before 

the manager can be run.   

 Stopping the Manager will not stop the Service  

 

 AWG3-2518 Improve connection status summaries, colors and title bar. 

SECURITY FIXES 
None. 

BUG FIXES 
AWG3-2511, AWG3-2517 Fix memory leaks and Microsoft Windows handle leaks. 
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VERSION 10.1.20.164 (June 12, 2020) 

Installer version 10.1.20.164 

Manager version 3.1.16.1 

Driver version  7.1.1.105 (Microsoft Windows 10, Server 2016, and Server 2019) 

Driver version  7.1.0.106 (Microsoft Windows 7, 8.1, and Server 2012-R2) 

 

NEW FEATURES 
Added version numbers in About Dialog for Manager, Drivers, and Installer.  JIRA AWG3-2423.    

ENHANCEMENTS 
Improved Manager logging especially in Service Mode.  JIRAs AWG3-2411, AWG3-2414 

SECURITY FIXES 
None. 

BUG FIXES 

1. The AnywhereUSB Manager Installer sometimes fails to generate desktop and “Start Menu” 

shortcuts when installing on Microsoft Windows Server 2012-R2, 2016, and 2019.   Fixed. JIRA 

AWG3-2358. 

2. On Microsoft Windows 7 installs, the AnywhereUSB Manager Installer sometimes incorrectly 

warns that it cannot install because Microsoft Windows has not been updated for SHA-2 Code 

signing support. Fixed. JIRA AWG3-2266. 

3. Certain USB devices connected to AnywhereUSB Plus Hubs did not operate correctly on 

Microsoft Windows 7, 8.1, and Server 2012-R2.  Fixed.  JIRA AWG3-2295. 
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VERSION 10.1.19.160 (January 29, 2020) 

 

 Installer version 10.1.19.160 

 Manager version 3.1.14.1 

 Driver version 7.1.1.105 

 
This is a recommended release because of increased USB device support and new features.  Users 
upgrading AnywhereUSB Plus hubs to 19.11 firmware MUST upgrade their AnywhereUSB 
Manager to this version or higher.  

NEW FEATURES 
None. 

ENHANCEMENTS 
Added logging in Microsoft Windows Service mode. 

SECURITY FIXES 
None. 

BUG FIXES 

4. Certain USB devices connected to AnywhereUSB Plus hubs did not operate correctly on 

Microsoft Windows 10.  Fixed. 

5. Manager may “assert” if you reconfigure the groups assigned to a client.  Fixed. 

 

VERSION 10.1.17.156 (September 10, 2019) 

 Installer version 10.1.17.156 

 Manager version 3.1.13.1 

 Driver version 7.1.0.104 

NEW FEATURES 

None 

ENHANCEMENTS 

1. Enhancement to mDNS client for to better handle multiple IP addresses in support of future 

firmware features. 

SECURITY FIXES 
None. 

BUG FIXES 

1. Manager may “assert” if you reconfigure the groups assigned to a client.  This issue will be 

addressed in the next release. 
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VERSION 10.1.16.155 (July 11, 2019) 

 Installer version 10.1.16.155 

 Manager version 3.1.12.1 

 Driver version 7.1.0.104 

NEW FEATURES 

None 

ENHANCEMENTS 

1. Enable manager to run as a service. Service mode configuration is independent from stand- 

alone mode. 

2. Manager commands can be scripted. 

3. Added support for Microsoft Windows Server 2019 

SECURITY FIXES 
None. 

BUG FIXES 
None. 

 

VERSION 10.1.2.93 (January 2, 2019) 

 Installer version 10.1.2.93 

 Manager version 3.1.1.9 

 Driver version 7.1.0.104 
 

This is the initial release of AnywhereUSB Manager for Microsoft Windows by Digi International.   

 


